TeaSpeak

TeaSpeak 1.0.19-beta

No permission to download

WolverinDEV

Restricted
Joined
Sep 21, 2015
Messages
42
Reaction score
34
Points
62
Age
31
@Zalati Read the error: (stdin: is not a tty). This happends if you run this as root, but you could fix this by just googeling this error :)

@Asphyxia
Hello, i already thought about a Web client, but im not fluent in writing web applications so i dropped this idea for this moment, but i already build the basics for multiple protocols.
I already got the suggestion to add a Mumble support, and i guess as soon my TeaSpeak server runs stable with the music bot, i would implement this.
(But if you want you could create a web based client, and we may could think about a standard protocol agreement. :)
 

Harrasan

Restricted
Joined
Jul 18, 2015
Messages
44
Reaction score
26
Points
50
Age
43
Great project! Could you try implementing WebRTC? Having a TS-like server providing a WebRTC interface would be awesome! Would make me switch to TeaSpeak immediately...

:)
 

Harrasan

Restricted
Joined
Jul 18, 2015
Messages
44
Reaction score
26
Points
50
Age
43
The server crashes when you try to delete the last (default) channel.
 

WolverinDEV

Restricted
Joined
Sep 21, 2015
Messages
42
Reaction score
34
Points
62
Age
31
You cant delete the default channel :)
All other stuff should be fixed in 1.0.21-Beta (Channel tree broke when you're create a channel with a specific order id)
 

Harrasan

Restricted
Joined
Jul 18, 2015
Messages
44
Reaction score
26
Points
50
Age
43
I tried to delete the channel via query by accident. It was the last channel on the server.

What do you think about WebRTC?
 

WolverinDEV

Restricted
Joined
Sep 21, 2015
Messages
42
Reaction score
34
Points
62
Age
31
And again a big music bot update!
Check out the newest verion on TeaSpeak.de

Changelog:
Code:
Fixed grant permission for b_client_music_channel_list
Fixed grant permission for b_client_music_server_list
Added new permission b_virtualserver_modify_music_bot_limit
Added new server property virtualserver_music_bot_limit
Big music bot update
Improved Youtube (streaming now not downloading)
Added stream support
Added Youtube stream support (May not working because of Googlevideo stuff)
Added volume support
Moved RSA puzzle from a single vs instance to global
Some little performance improvements
Fixed small channel delete crash
 

LetsBlade

Member
Joined
Jan 7, 2017
Messages
102
Reaction score
14
Points
53
Age
19
Possible to deactivate the Kick for more then 3 Badges? (Maybe Global or for certain Ranks?)
 

karkow

Member
Joined
Nov 16, 2015
Messages
24
Reaction score
3
Points
35
Age
33
Which Linux distribution is preferred?
What packages do I need to install?

I use ubuntu 16.04.4 LTS.
./teastart_minimal.sh works but then ./teastart.sh - noting happend. ./teastart.sh status - No server running (tpid.pid is missing).

[ERROR] | Instance tick tooks to long (119)
[ERROR] 3 | Found delay while ticking server. (Delay: 518ms)
- What does it mean?

My sinusbot can't connect
- Unregister client connection. Lock: 6/0x7f33b0003d50 s: 0x21eefa0
 
Last edited:

karkow

Member
Joined
Nov 16, 2015
Messages
24
Reaction score
3
Points
35
Age
33
ver. 1.1.0-beta teastart.sh works normally.
Thank you for your work!

I have restore (YaTQA) the server backup where I am serveradmin. On TeaSpeak I have only a ".mbot format" green the rest of the commands are red.
What permissions?
Oh! I see :D

"Invalid granted permission" - when I want add this perms. Why YaTQA don't see this perm?
 
Last edited:

PeterDEV

New Member
Joined
Feb 28, 2018
Messages
45
Reaction score
5
Points
13
Age
24
I have a question. Are the protocols / classes (telnet commands) identical to those of the unmodified version of the server?
 

WolverinDEV

Restricted
Joined
Sep 21, 2015
Messages
42
Reaction score
34
Points
62
Age
31
@PeterDEV most of it but not everything. I'm planning to create a full documentation for all the commands, but I hadn't enough time yet. So you could find most of the changes on github at Changes.md
 

sayan14

Member
Joined
Mar 11, 2017
Messages
24
Reaction score
5
Points
38
Age
25
tested latest version and works great without any crashes, amazing project Wolverin =)
 

TheNemic

Member
Joined
Dec 3, 2015
Messages
9
Reaction score
1
Points
35
Age
40
Thanks for a very nice project :) but then I run teaspeak_minimal.sh I get this error, and no more is happening:

Code:
sh teastart_minimal.sh
teastart_minimal.sh: 10: teastart_minimal.sh: Syntax error: "do" unexpected (expecting "fi")
[email protected]:~/teaspeak$ Package: libav-tools
Status: install ok installed
Priority: optional
Section: video
Installed-Size: 9189
Maintainer: Ubuntu Developers <[email protected]>
Architecture: amd64
Source: libav
Version: 6:9.20-0ubuntu0.14.04.1
Replaces: libavcodec-extra-53 (<< 4:0.6~)
Depends: libavcodec54 (>= 6:9.1-1) | libavcodec-extra-54 (>= 6:9.20), libavdevice53 (>= 6:9.1-1), libavfilter3 (>= 6:9.1-1), libavformat54 (>= 6:9.1-1), libavresample1 (>= 6:9.1-1), libavutil52 (>= 6:9.1-1), libbz2-1.0, libc6 (>= 2.14), libgnutls26 (>= 2.12.17-0), libgsm1 (>= 1.0.13), libmp3lame0, libopenjpeg2, libopus0 (>= 1.0.3), librtmp0 (>= 2.3), libschroedinger-1.0-0 (>= 1.0.7), libsdl1.2debian (>= 1.2.11), libspeex1 (>= 1.2~beta3-1), libswscale2 (>= 6:9.1-1), libtheora0 (>= 1.0), libva1 (>> 1.3.0~), libvorbis0a (>= 1.1.2), libvorbisenc2 (>= 1.1.2), libvpx1 (>= 1.0.0), libx264-142, libxvidcore4 (>= 1.2.2), zlib1g (>= 1:1.2.0)
Pre-Depends: dpkg (>= 1.15.7.2~)
Suggests: frei0r-plugins (>= 1.3)
Conflicts: ffprobe
Conffiles:
 /etc/avserver.conf 43e9d812fb6ca7464d13eec57d6b3c17
Description: Multimedia player, server, encoder and transcoder
 Libav is a complete, cross-platform solution to decode, encode, record,
 convert and stream audio and video.
 .
 This package contains the avplay multimedia player, the avserver
 streaming server, the avconv audio and video encoder, and the avprobe
 stream analyzer.  They support most existing file formats (AVI, MPEG,
 OGG, Matroska, ASF...) and encoding formats (MPEG, DivX, MPEG4, AC3,
 DV...). Additionally, it contains the qt-faststart utility which
 rearranges Quicktime files to facilitate network streaming.
 .
 This package also serves as a replacement for the former 'ffmpeg'
 package.
Homepage: http://libav.org/
Original-Maintainer: Debian Multimedia Maintainers <[email protected]>
 

WolverinDEV

Restricted
Joined
Sep 21, 2015
Messages
42
Reaction score
34
Points
62
Age
31
Hey,
well can you please give me your operating system?
And btw, you just could delete the first few lines until the LD_LIBRARY_PATH line.
Than all should work :)
 

TheNemic

Member
Joined
Dec 3, 2015
Messages
9
Reaction score
1
Points
35
Age
40
I'am running Ubuntu, but then I run ./TeaSpeakServer, I get this:

./TeaSpeakServer: error while loading shared libraries: libTeaMusic.so: cannot open shared object file: No such file or directory
 

Top