JTS3ServerMod HostingEdition

JTS3ServerMod HostingEdition 5.5.7 5.5.7

No permission to download

Supervisor

Administrator
Joined
Apr 27, 2015
Messages
1,738
Points
295
Location
Germany
You can download v6.1.5, but you cannot use it since it's protected.
We decided to not release the Crack for it. The last unprotected version is 5.5.7
 

hamza32231

Member
Joined
Jan 13, 2016
Messages
16
Points
35
Age
26
how to fix this : Reached no service on that IP address / port! Make sure that the JTS3ServerMod process is running and the telnet_enable and telnet_run_forever settings at the JTS3ServerMod_InstanceManager.cfg are enabled!
 

Alligatoras

Administrator
Joined
Mar 31, 2016
Messages
2,071
Points
341
Age
26
Location
Greece
how to fix this : Reached no service on that IP address / port! Make sure that the JTS3ServerMod process is running and the telnet_enable and telnet_run_forever settings at the JTS3ServerMod_InstanceManager.cfg are enabled!
what abou open the telnet connection?
 

BayX

I'm the Root. Fear me!
Joined
Dec 18, 2015
Messages
74
Points
56
Location
Sweden
Hey peeps!

I have some issues to get the webinterface connected to my VPS which holds the JTS3 server.
Here's the following list of what I did:
  • Fresh install of CentOS 6.5
  • Updated the server
  • Installed Java SDK and Screen
  • Copied the JTS3 folder to root folder (tried setting up a new user and duplicated the folder to that one also)
  • Changed all necessary settings in both JTS3ServerMod_InstanceManager.cfg and JTS3ServerMod_server.cfg
  • Started the server with the command "screen -d -m -S ts3bot java -jar JTS3ServerMod.jar"
All logs indicates that the server is running. Here's the logs:

JTS3ServerMod_InstanceManager.log:
Code:
2017-09-23 09:25:43    START_MANAGER    JTS3ServerMod 5.5.7 Hosting Edition (28.12.2015) Instance Manager started...
2017-09-23 09:25:43    CONFIG    Bot chat command !exec is disabled!
2017-09-23 09:25:43    CONFIG    Multi IP Mode disabled!
2017-09-23 09:25:43    CONFIG    MySQL mode disabled!
2017-09-23 09:25:44    START_INSTANCE    Start virtual bot instance bot1...
2017-09-23 09:25:44    TELNET_START    Telnet interface started on port 5873!
JTS3ServerMod_server1.log:
Code:
2017-09-23 09:25:44    JTS3ServerMod    STATUS    Virtual bot instance "bot1" starts now
2017-09-23 09:25:44    JTS3ServerMod    STATUS    Activate log level: ERROR
Got the error message from the webinterface: Reached no service on that IP address / port! Make sure that the JTS3ServerMod process is running and the telnet_enable and telnet_run_forever settings at the JTS3ServerMod_InstanceManager.cfg are enabled!

I checked the settings "telnet_enable" & "telnet_run_forever" and both of them are enabled.
I tried turn the firewall of to see if that was the problem by executing "service iptables stop". But nothing seems to work..

Anyone has an idea?
 

XRV-Webix

Member
Joined
May 2, 2016
Messages
111
Points
64
Age
40
Location
Portugal
Hey peeps!

I have some issues to get the webinterface connected to my VPS which holds the JTS3 server.
Here's the following list of what I did:
  • Fresh install of CentOS 6.5
  • Updated the server
  • Installed Java SDK and Screen
  • Copied the JTS3 folder to root folder (tried setting up a new user and duplicated the folder to that one also)
  • Changed all necessary settings in both JTS3ServerMod_InstanceManager.cfg and JTS3ServerMod_server.cfg
  • Started the server with the command "screen -d -m -S ts3bot java -jar JTS3ServerMod.jar"
All logs indicates that the server is running. Here's the logs:

JTS3ServerMod_InstanceManager.log:
Code:
2017-09-23 09:25:43    START_MANAGER    JTS3ServerMod 5.5.7 Hosting Edition (28.12.2015) Instance Manager started...
2017-09-23 09:25:43    CONFIG    Bot chat command !exec is disabled!
2017-09-23 09:25:43    CONFIG    Multi IP Mode disabled!
2017-09-23 09:25:43    CONFIG    MySQL mode disabled!
2017-09-23 09:25:44    START_INSTANCE    Start virtual bot instance bot1...
2017-09-23 09:25:44    TELNET_START    Telnet interface started on port 5873!
JTS3ServerMod_server1.log:
Code:
2017-09-23 09:25:44    JTS3ServerMod    STATUS    Virtual bot instance "bot1" starts now
2017-09-23 09:25:44    JTS3ServerMod    STATUS    Activate log level: ERROR
Got the error message from the webinterface: Reached no service on that IP address / port! Make sure that the JTS3ServerMod process is running and the telnet_enable and telnet_run_forever settings at the JTS3ServerMod_InstanceManager.cfg are enabled!

I checked the settings "telnet_enable" & "telnet_run_forever" and both of them are enabled.
I tried turn the firewall of to see if that was the problem by executing "service iptables stop". But nothing seems to work..

Anyone has an idea?
Pay attention to your logs. To use the bot with it's hosting edition website, you need to configure the MySQL. Otherwise, it won't work.
 

BayX

I'm the Root. Fear me!
Joined
Dec 18, 2015
Messages
74
Points
56
Location
Sweden
Hi @XRV-Webix,

I read the logs, and it didn't say that it was an error. Just that it was disabled.
But I will correct it and test again!
 

BayX

I'm the Root. Fear me!
Joined
Dec 18, 2015
Messages
74
Points
56
Location
Sweden
Hi again @XRV-Webix,

I did read the documentation, but I didn't see anything about a MySQL was required.

Maybe I missed it, who knows :p
 

BayX

I'm the Root. Fear me!
Joined
Dec 18, 2015
Messages
74
Points
56
Location
Sweden
I changed the MySQL settings, and now I get the following error in the logs:
Code:
2017-09-23 21:27:37    START_MANAGER    JTS3ServerMod 5.5.7 Hosting Edition (28.12.2015) Instance Manager started...
2017-09-23 21:27:37    CONFIG    Bot chat command !exec is disabled!
2017-09-23 21:27:37    CONFIG    Multi IP Mode disabled!
2017-09-23 21:27:38    LOGGER_SQL_ERROR    Critical: Cannot connect to MySQL server for logging!
2017-09-23 21:27:38    JTS3ServerMod 5.5.7 Hosting Edition (28.12.2015): EXCEPTION
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:400)
    at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1038)
    at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:339)
    at com.mysql.jdbc.ConnectionImpl.coreConnect(ConnectionImpl.java:2247)
    at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(ConnectionImpl.java:2280)
    at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2079)
    at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:794)
    at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection.java:44)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:400)
    at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:399)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:325)
    at java.sql.DriverManager.getConnection(DriverManager.java:664)
    at java.sql.DriverManager.getConnection(DriverManager.java:247)
    at de.stefan1200.util.MySQLConnect.connect(MySQLConnect.java:55)
    at de.stefan1200.jts3servermod.MyLogger.initDB(MyLogger.java:49)
    at de.stefan1200.jts3servermod.MyLogger.<init>(MyLogger.java:33)
    at de.stefan1200.jts3servermod.InstanceManager.loadConfig(InstanceManager.java:1073)
    at de.stefan1200.jts3servermod.InstanceManager.<init>(InstanceManager.java:155)
    at de.stefan1200.jts3servermod.JTS3ServerMod.main(JTS3ServerMod.java:249)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
    at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:589)
    at com.mysql.jdbc.StandardSocketFactory.connect(StandardSocketFactory.java:214)
    at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:298)
    ... 20 more
2017-09-23 21:27:38    CONFIG    MySQL mode enabled!
2017-09-23 21:27:38    MYSQL_ERROR    Error while connecting to database: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
2017-09-23 21:27:38    JTS3ServerMod 5.5.7 Hosting Edition (28.12.2015): EXCEPTION
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:400)
    at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1038)
    at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:339)
    at com.mysql.jdbc.ConnectionImpl.coreConnect(ConnectionImpl.java:2247)
    at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(ConnectionImpl.java:2280)
    at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2079)
    at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:794)
    at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection.java:44)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:400)
    at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:399)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:325)
    at java.sql.DriverManager.getConnection(DriverManager.java:664)
    at java.sql.DriverManager.getConnection(DriverManager.java:247)
    at de.stefan1200.util.MySQLConnect.connect(MySQLConnect.java:55)
    at de.stefan1200.jts3servermod.InstanceManager.loadInstanceListMySQL(InstanceManager.java:1207)
    at de.stefan1200.jts3servermod.InstanceManager.loadConfig(InstanceManager.java:1109)
    at de.stefan1200.jts3servermod.InstanceManager.<init>(InstanceManager.java:155)
    at de.stefan1200.jts3servermod.JTS3ServerMod.main(JTS3ServerMod.java:249)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
    at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:589)
    at com.mysql.jdbc.StandardSocketFactory.connect(StandardSocketFactory.java:214)
    at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:298)
    ... 19 more
2017-09-23 21:27:38    QUIT_MANAGER    InstanceManager config file does not exists or is not readable, quitting now...
I noticed the errors that I colored red, but the strange thing is that the database can be connected from both internal and external. Anything I missed in the log?..
 

Top